Commit f5c72a78 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Remove kmime dep for only mimetype for a test apps

parent a9bed56a
Pipeline #84444 passed with stage
in 12 minutes and 16 seconds
......@@ -10,6 +10,5 @@ Dependencies:
'kde/pim/akonadi' : '@same'
'kde/pim/akonadi-contacts' : '@same'
'kde/pim/kimap' : '@same'
'kde/pim/kmime' : '@same'
'kde/pim/kpimtextedit' : '@same'
'kde/pim/libkdepim' : '@same'
......@@ -37,7 +37,6 @@ set(PIMCOMMON_LIB_VERSION ${PIM_VERSION})
set(AKONADICONTACT_LIB_VERSION "5.18.40")
set(LIBKDEPIM_LIB_VERSION "5.18.40")
set(QT_REQUIRED_VERSION "5.15.2")
set(KMIME_LIB_VERSION "5.18.40")
set(KIMAP_LIB_VERSION "5.18.40")
set(KPIMTEXTEDIT_LIB_VERSION "5.18.40")
set(AKONADI_VERSION "5.18.41")
......@@ -92,7 +91,6 @@ configure_file(config-akonadi-search.h.in ${CMAKE_CURRENT_BINARY_DIR}/src/config
if(BUILD_TESTING)
find_package(KF5Mime ${KMIME_LIB_VERSION} CONFIG REQUIRED)
add_definitions(-DBUILD_TESTING)
endif(BUILD_TESTING)
......
add_executable(selectmultiselectiondialog_gui selectmultiselectiondialog_gui.cpp)
target_link_libraries(selectmultiselectiondialog_gui
KF5::Mime
KF5::PimCommonAkonadi
KF5::I18n
)
......@@ -7,7 +7,6 @@
#include "pimcommonakonadi_debug.h"
#include "folderdialog/selectmulticollectiondialog.h"
#include <KMime/Message>
#include <QApplication>
#include <QCommandLineParser>
#include <QStandardPaths>
......@@ -20,7 +19,7 @@ int main(int argc, char **argv)
parser.addVersionOption();
parser.addHelpOption();
parser.process(app);
auto dialog = new PimCommon::SelectMultiCollectionDialog(KMime::Message::mimeType());
auto dialog = new PimCommon::SelectMultiCollectionDialog(QStringLiteral("message/rfc822"));
dialog->exec();
delete dialog;
return 0;
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment