Commit ebf5d2d3 authored by Laurent Montel's avatar Laurent Montel 😁

Add warning about plugin version

parent ac8d803e
......@@ -22,6 +22,7 @@
#include <kpluginmetadata.h>
#include <QFileInfo>
#include <QSet>
#include <QDebug>
using namespace PimCommon;
......@@ -105,6 +106,8 @@ void CustomToolsPluginManagerPrivate::initializePluginList()
info.plugin = Q_NULLPTR;
mPluginList.push_back(info);
unique.insert(info.saveName());
} else {
qWarning() << "Plugin " << info.metaData.name() << " doesn't have correction plugin version. It will not be loaded.";
}
}
QVector<CustomToolsPluginInfo>::iterator end(mPluginList.end());
......
......@@ -25,6 +25,7 @@
#include <QVariant>
#include <QSet>
#include <QVariantList>
#include <QDebug>
using namespace PimCommon;
......@@ -117,6 +118,8 @@ bool GenericPluginManagerPrivate::initializePlugins()
info.plugin = Q_NULLPTR;
mPluginList.push_back(info);
unique.insert(info.saveName());
} else {
qWarning() << "Plugin " << info.metaData.name() << " doesn't have correction plugin version. It will not be loaded.";
}
}
QVector<GenericPluginInfo>::iterator end(mPluginList.end());
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment