Commit 50762416 authored by Volker Krause's avatar Volker Krause
Browse files

Don't link against QtWidgets on Android

Also, remove the dependency on KNotification, that seems only be needed
for its transitive QtWidget dependency atm.
parent 992f0657
Pipeline #71259 passed with stage
in 17 seconds
......@@ -49,13 +49,14 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
Kirigami2
I18n
CoreAddons
Notifications
QuickCharts
)
find_package(KF5 0.3.0 REQUIRED COMPONENTS KWeatherCore)
if (ANDROID)
find_package(OpenSSL REQUIRED)
else ()
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS Widgets)
endif()
if (NOT ANDROID AND BUILD_PLASMOID)
......
......@@ -28,11 +28,9 @@ add_executable(kweather ${kweather_SRCS})
target_link_libraries(kweather
Qt5::Qml
Qt5::QuickControls2
Qt5::Widgets
Qt5::Network
KF5::I18n
KF5::CoreAddons
KF5::Notifications
KF5::QuickCharts
KF5::KWeatherCore
kweatherLib
......@@ -94,6 +92,8 @@ if (ANDROID)
weather-storm-day
weather-storm-night
)
else()
target_link_libraries(kweather Qt5::Widgets)
endif()
if (UNIX AND (NOT ANDROID))
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment