Commit 3968649a authored by Laurent Montel's avatar Laurent Montel 😁

now that qt4 was dropped we can use specific ECM/Qt/KF5 version

parent 87fc8f46
cmake_minimum_required(VERSION 3.0)
project(breeze)
set(PROJECT_VERSION "5.18.80")
set(PROJECT_VERSION_MAJOR 5)
cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
set(KF5_MIN_VERSION "5.66.0")
include(GenerateExportHeader)
include(WriteBasicConfigVersionFile)
include(FeatureSummary)
find_package(ECM 0.0.9 REQUIRED NO_MODULE)
find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} ${CMAKE_SOURCE_DIR}/cmake)
include(ECMInstallIcons)
......@@ -36,7 +37,7 @@ if (WITH_WALLPAPERS)
add_subdirectory(wallpapers)
endif()
find_package(KF5Package CONFIG REQUIRED)
find_package(KF5Package ${KF5_MIN_VERSION} CONFIG REQUIRED)
kpackage_install_package(lookandfeel.dark org.kde.breezedark.desktop look-and-feel plasma)
if(EXISTS ${CMAKE_SOURCE_DIR}/po AND IS_DIRECTORY ${CMAKE_SOURCE_DIR}/po)
find_package(KF5I18n CONFIG REQUIRED)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment