Commit 18488d34 authored by Heiko Becker's avatar Heiko Becker
Browse files

Drop no longer necessary Qt5X11Extras/Qt6GuiPrivate dependency

raiseWindow() no longer uses QX11Info::isPlatformX11() since [1], which
was the reason for the Qt5X11Extras/Qt6GuiPrivate dependency AFAICT.

[1] 9f1358f0
parent 2c00fceb
......@@ -24,12 +24,6 @@ include(KDEClangFormat)
include(KDEGitCommitHooks)
find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED CONFIG COMPONENTS Widgets Test Network Xml Concurrent DBus Quick)
if (QT_MAJOR_VERSION STREQUAL "5")
find_package(Qt5X11Extras REQUIRED)
elseif (QT_MAJOR_VERSION STREQUAL "6")
find_package(Qt${QT_MAJOR_VERSION} ${REQUIRED_QT_VERSION} CONFIG REQUIRED Gui) # qtx11extras_p.h
endif()
find_package(PkgConfig REQUIRED)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED CoreAddons Config Crash DBusAddons I18n Archive XmlGui ItemModels KIO Declarative KCMUtils IdleTime Notifications)
......
......@@ -51,13 +51,6 @@ target_link_libraries(plasma-discover PUBLIC
Discover::Common
)
if (QT_MAJOR_VERSION STREQUAL "5")
target_link_libraries(plasma-discover PUBLIC Qt::X11Extras)
elseif (QT_MAJOR_VERSION STREQUAL "6")
target_link_libraries(plasma-discover PUBLIC Qt6::GuiPrivate)
endif()
if (TARGET KUserFeedbackCore)
target_link_libraries(plasma-discover PRIVATE KUserFeedbackCore)
target_compile_definitions(plasma-discover PRIVATE WITH_FEEDBACK=1)
......
......@@ -22,11 +22,6 @@
#include <QWindow>
#include <QProcessEnvironment>
#if QT_VERSION < QT_VERSION_CHECK(6, 0, 0)
#include <QX11Info>
#else
#include <private/qtx11extras_p.h>
#endif
typedef QHash<QString, DiscoverObject::CompactMode> StringCompactMode;
Q_GLOBAL_STATIC_WITH_ARGS(StringCompactMode,
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment