Commit 76a8d61d authored by Heiko Becker's avatar Heiko Becker
Browse files

Drop no longer necessary KF5ItemModels dependency

AFAICT the last usage was removed with
bd6e1a27.
parent 18488d34
Pipeline #191402 passed with stage
in 3 minutes and 25 seconds
......@@ -19,7 +19,6 @@ Dependencies:
'frameworks/ki18n': '@latest'
'frameworks/kidletime': '@latest'
'frameworks/kio': '@latest'
'frameworks/kitemmodels': '@latest'
'frameworks/knewstuff': '@latest'
'frameworks/knotifications': '@latest'
'frameworks/kservice': '@latest'
......
......@@ -26,7 +26,7 @@ find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED CONFIG COMPONENTS
find_package(PkgConfig REQUIRED)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED CoreAddons Config Crash DBusAddons I18n Archive XmlGui ItemModels KIO Declarative KCMUtils IdleTime Notifications)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED CoreAddons Config Crash DBusAddons I18n Archive XmlGui KIO Declarative KCMUtils IdleTime Notifications)
find_package(KF5Kirigami2 2.7.0)
find_package(packagekitqt5 1.0.1 CONFIG)
......
......@@ -40,7 +40,6 @@ target_link_libraries(plasma-discover PUBLIC
KF5::Crash
KF5::DBusAddons
KF5::I18n
KF5::ItemModels
KF5::ConfigGui
KF5::KIOCore
KF5::WindowSystem
......
......@@ -57,7 +57,6 @@ PUBLIC
Qt::Qml
Qt::Gui
KF5::I18n
KF5::ItemModels
PRIVATE
Qt::Xml
KF5::CoreAddons
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment