Commit f05895f3 authored by Nate Graham's avatar Nate Graham
Browse files

Bump KF5 version requirement to 5.45

Summary: Discover depends on a feature in Kirigami (D11197) that was/is being introduced in 5.45. This patch marks that dependency in CMake.

Test Plan: Still compiles when KF 5.45 is installed; doesn't when it isn't.

Reviewers: apol, #discover_software_store

Reviewed By: apol, #discover_software_store

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D12035
parent fa278f29
......@@ -19,7 +19,7 @@ include(GenerateExportHeader)
find_package(PkgConfig REQUIRED)
find_package(KF5 5.42 REQUIRED CoreAddons Config Crash DBusAddons I18n Archive XmlGui ItemModels KIO)
find_package(KF5 5.45 REQUIRED CoreAddons Config Crash DBusAddons I18n Archive XmlGui ItemModels KIO)
find_package(KF5Kirigami2 2.1.0)
find_package(packagekitqt5 CONFIG)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment