Commit fff2ff0d authored by Friedrich W. H. Kossebau's avatar Friedrich W. H. Kossebau
Browse files

Move cmake_minimum_required to top, bump min cmake version to 3.0

parent 6ae16cec
cmake_minimum_required(VERSION 3.0)
project(kdeplasma-addons)
set(PROJECT_VERSION "5.12.80")
set(PROJECT_VERSION_MAJOR 5)
cmake_minimum_required(VERSION 2.8.12)
################# Disallow in-source build #################
if("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")
message(FATAL_ERROR "plasma requires an out of source build. Please create a separate build directory and run 'cmake path_to_plasma [options]' there.")
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment