Commit 2276e09b authored by David Faure's avatar David Faure

Skip the dict applet if Qt5WebEngine isn't available

As requested by Rik Mills for the kubuntu packaging
(because QtWebEngine is only available on x86 and arm)

CCMAIL: rikmills@kubuntu.org
parent 0274ed83
find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG COMPONENTS WebEngine)
set_package_properties(Qt5WebEngine PROPERTIES DESCRIPTION "needed by the dict applet"
URL "https://doc.qt.io/qt-5/qtwebengine-index.html"
)
if (Qt5WebEngine_FOUND)
#######################################################################################
# Package (metadata.desktop and QML)
plasma_install_package(package org.kde.plasma_applet_dict)
......@@ -10,8 +18,6 @@ install(FILES accessories-dictionary.svgz
#######################################################################################
# C++ Plugin
find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED WebEngine)
add_definitions(-DTRANSLATION_DOMAIN="plasma_applet_org.kde.plasma.dict")
set(dict_SRCS
......@@ -32,3 +38,4 @@ target_link_libraries(dictplugin
install(FILES plugin/qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/plasma/private/dict)
install(TARGETS dictplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/plasma/private/dict)
endif()
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment