Commit fddcf40a authored by Nicolas Fella's avatar Nicolas Fella
Browse files

Require C++17

We agreed to use C++17 in Plasma. Document this decision here
parent ed906d3b
......@@ -6,6 +6,9 @@ cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
set(QT_MIN_VERSION "5.14.0")
set(KF5_MIN_VERSION "5.64.0")
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
include(FeatureSummary)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment