Commit 5d1713b1 authored by Vlad Zahorodnii's avatar Vlad Zahorodnii
Browse files

Require C++14

We need to capture a variable in a lambda in the xdg-shell protocol
wrappers. This requires C++14.

Since KWin already requires C++14, it shouldn't be a big deal.
parent a8cfb02d
......@@ -7,6 +7,9 @@ set(KF5_MIN_VERSION "5.70.0")
project(KWaylandServer VERSION ${PROJECT_VERSION})
set(CMAKE_CXX_STANDARD 14)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
# ECM setup
include(FeatureSummary)
find_package(ECM ${KF5_MIN_VERSION} NO_MODULE REQUIRED)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment