Commit 2bef3d08 authored by Martin Flöser's avatar Martin Flöser
Browse files

Check maximum supported version in Client::Registry

Ensure that we do not connect to a version which our client library
does not support. If we would allow higher versions we would run the
risk that the wayland library calls into not existing callbacks.
parent 4d77c197
......@@ -134,7 +134,7 @@ void TestWaylandRegistry::testCreate()
/* registry should now about the interface now */ \
QVERIFY(registry.hasInterface(interface)); \
QVERIFY(!registry.bindMethod(name+1, version)); \
QVERIFY(!registry.bindMethod(name, version+1)); \
QVERIFY(registry.bindMethod(name, version+1)); \
auto *c = registry.bindMethod(name, version); \
QVERIFY(c); \
destroyFunction(c); \
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment