Commit bfcf312e authored by Vlad Zahorodnii's avatar Vlad Zahorodnii
Browse files

Drop unused libwayland-cursor dependency

KWin doesn't need libwayland-cursor since cb7a9456.
parent f5a75e70
...@@ -170,12 +170,12 @@ if (epoxy_HAS_GLX) ...@@ -170,12 +170,12 @@ if (epoxy_HAS_GLX)
endif() endif()
endif() endif()
find_package(Wayland 1.2 REQUIRED COMPONENTS Cursor OPTIONAL_COMPONENTS Egl) find_package(Wayland 1.2 OPTIONAL_COMPONENTS Egl)
set_package_properties(Wayland PROPERTIES set_package_properties(Wayland PROPERTIES
TYPE REQUIRED TYPE REQUIRED
PURPOSE "Required for building KWin with Wayland support" PURPOSE "Required for building KWin with Wayland support"
) )
add_feature_info("Wayland::EGL" Wayland_Egl_FOUND "Enable building of Wayland backend and QPA with EGL support.") add_feature_info("Wayland::EGL" Wayland_Egl_FOUND "Enable building of Wayland backend.")
set(HAVE_WAYLAND_EGL FALSE) set(HAVE_WAYLAND_EGL FALSE)
if (Wayland_Egl_FOUND) if (Wayland_Egl_FOUND)
set(HAVE_WAYLAND_EGL TRUE) set(HAVE_WAYLAND_EGL TRUE)
...@@ -685,7 +685,6 @@ set(kwin_XCB_LIBS ...@@ -685,7 +685,6 @@ set(kwin_XCB_LIBS
set(kwin_WAYLAND_LIBS set(kwin_WAYLAND_LIBS
KF5::WaylandClient KF5::WaylandClient
Plasma::KWaylandServer Plasma::KWaylandServer
Wayland::Cursor
XKB::XKB XKB::XKB
${CMAKE_THREAD_LIBS_INIT} ${CMAKE_THREAD_LIBS_INIT}
) )
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment