Commit 88e56f63 authored by Martin Flöser's avatar Martin Flöser

Raise minimum required Mesa version to 10.0

Summary:
The currently minimum required Mesa version was 8.0 and KWin had special
caseing for Mesa 9.1. This is no longer realistic, no distribution
provides such an old Mesa version. So let's increase the version a
little bit.

Overview of Mesa versions supported by distributions:
 * Debian stable (stretch): 13.0
 * Debian oldstable (jessie): 10.3
 * Debian oldstable backports: 13.0
 * Debian oldoldstable (wheezy): 8.0
 * Ubuntu 16.04 LTS: 11.2
 * Ubuntu 16.04 LTS updates: 12.0
 * Ubuntu 17.04: 17.0
 * openSUSE Tumbleweed: 17.1
 * openSUSE Leap 42.2: 11.2
 * openSUSE Leap 42.3: 17.0
 * Arch: 17.1
 * Fedora 24: 12.0
 * Fedora 25: 17.0
 * Fedora 26: 17.1

Test Plan: Compiles

Reviewers: #kwin, #plasma

Subscribers: plasma-devel, kwin

Tags: #kwin

Differential Revision: https://phabricator.kde.org/D6462
parent 46085d3b
......@@ -78,9 +78,6 @@ void LanczosFilter::init()
// The lanczos filter is reported to be broken with the Intel driver prior SandyBridge
if (gl->driver() == Driver_Intel && gl->chipClass() < SandyBridge)
return;
// Broken on Intel chips with Mesa 9.1 - BUG 313613
if (gl->driver() == Driver_Intel && gl->mesaVersion() >= kVersionNumber(9, 1) && gl->mesaVersion() < kVersionNumber(9, 2))
return;
// also radeon before R600 has trouble
if (gl->isRadeon() && gl->chipClass() < R600)
return;
......
......@@ -407,8 +407,8 @@ SceneOpenGL::SceneOpenGL(OpenGLBackend *backend, QObject *parent)
init_ok = false;
return; // error
}
if (glPlatform->isMesaDriver() && glPlatform->mesaVersion() < kVersionNumber(8, 0)) {
qCCritical(KWIN_CORE) << "KWin requires at least Mesa 8.0 for OpenGL compositing.";
if (glPlatform->isMesaDriver() && glPlatform->mesaVersion() < kVersionNumber(10, 0)) {
qCCritical(KWIN_CORE) << "KWin requires at least Mesa 10.0 for OpenGL compositing.";
init_ok = false;
return;
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment