Commit 21992e38 authored by Friedrich W. H. Kossebau's avatar Friedrich W. H. Kossebau
Browse files

Require KDE Frameworks 5.42 and Qt 5.9

parent 758411f2
......@@ -3,8 +3,8 @@ cmake_minimum_required(VERSION 3.0)
project(kwrited)
set(PROJECT_VERSION "5.12.80")
set(QT_MIN_VERSION "5.4.0")
set(KF5_MIN_VERSION "5.10.0")
set(QT_MIN_VERSION "5.9.0")
set(KF5_MIN_VERSION "5.42.0")
remove_definitions(-DQT_NO_CAST_FROM_ASCII -DQT_STRICT_ITERATORS -DQT_NO_CAST_FROM_BYTEARRAY -DQT_NO_KEYWORDS)
......@@ -32,7 +32,7 @@ cmake_dependent_option(BUILD_AS_EXECUTABLE "Whether to build kwrited as executab
"KPty_HAVE_UTEMPTER" ON)
if (NOT BUILD_AS_EXECUTABLE)
find_package(KF5DBusAddons)
find_package(KF5DBusAddons ${KF5_MIN_VERSION})
set_package_properties(KF5DBusAddons PROPERTIES DESCRIPTION "Convenience classes for DBus"
TYPE REQUIRED
PURPOSE "Needed to build kwrited's KDED module"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment