Commit 71751b04 authored by Laurent Montel's avatar Laurent Montel 😁

USe KF5_MIN_VERSION

parent f28546cf
......@@ -39,8 +39,8 @@ option(BUILD_QCH "Build API documentation in QCH format (for e.g. Qt Assistant,
add_feature_info(QCH ${BUILD_QCH} "API documentation in QCH format (for e.g. Qt Assistant, Qt Creator & KDevelop)")
set(KF5_VERSION ${PROJECT_VERSION}) #When we are happy with the api, we can sync with frameworks
ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KSCREEN
set(KF5_MIN_VERSION ${PROJECT_VERSION}) #When we are happy with the api, we can sync with frameworks
ecm_setup_version(${KF5_MIN_VERSION} VARIABLE_PREFIX KSCREEN
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/kscreen_version.h"
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KF5ScreenConfigVersion.cmake"
SOVERSION 7)
......
......@@ -95,7 +95,7 @@ if(BUILD_QCH)
KF5Screen_QCH
NAME KScreen
BASE_NAME KF5Screen
VERSION ${KF5_VERSION}
VERSION ${KF5_MIN_VERSION}
ORG_DOMAIN org.kde
SOURCES # using only public headers, to cover only public API
${KScreen_REQ_HEADERS}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment