Commit c2314b46 authored by Nicolas Fella's avatar Nicolas Fella Committed by Arjen Hiemstra
Browse files

Use versionless Qt cmake target

This makes it easier to build against both Qt5 and Qt6

GIT_SILENT
parent 83abeb00
......@@ -16,6 +16,6 @@ ecm_qt_declare_logging_category(networkplugin_SRCS
configure_file(networkconstants.h.in networkconstants.h @ONLY)
add_library(ksysguard_plugin_network MODULE ${networkplugin_SRCS})
target_link_libraries(ksysguard_plugin_network Qt5::Core Qt5::DBus KF5::CoreAddons KF5::I18n KSysGuard::ProcessCore)
target_link_libraries(ksysguard_plugin_network Qt::Core Qt::DBus KF5::CoreAddons KF5::I18n KSysGuard::ProcessCore)
install(TARGETS ksysguard_plugin_network DESTINATION ${KDE_INSTALL_PLUGINDIR}/ksysguard/process)
add_library(ksysguard_plugin_nvidia MODULE nvidia.cpp)
target_link_libraries(ksysguard_plugin_nvidia Qt5::Core KSysGuard::ProcessCore KF5::I18n KF5::CoreAddons)
target_link_libraries(ksysguard_plugin_nvidia Qt::Core KSysGuard::ProcessCore KF5::I18n KF5::CoreAddons)
install(TARGETS ksysguard_plugin_nvidia DESTINATION ${KDE_INSTALL_PLUGINDIR}/ksysguard/process)
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment