Commit 1a02e143 authored by Laurent Montel's avatar Laurent Montel
Browse files

Prepare build system for building against qt6

parent db24643d
......@@ -4,8 +4,8 @@ project(plasma-browser-integration)
set(PROJECT_VERSION "5.24.80")
set(PROJECT_VERSION_MAJOR 5)
set(QT_MIN_VERSION "5.9.0")
set(KF5_MIN_VERSION "5.81.0")
set(QT_MIN_VERSION "5.15.0")
set(KF5_MIN_VERSION "5.90.0")
find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} )
......@@ -17,7 +17,7 @@ include(FeatureSummary)
include(KDEClangFormat)
include(KDEGitCommitHooks)
find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
Gui
DBus
Widgets
......
......@@ -20,4 +20,4 @@ target_link_libraries(browserintegrationreminder
KF5::KIOGui # for KIO::ApplicationLauncherJob
)
install(TARGETS browserintegrationreminder DESTINATION ${KDE_INSTALL_PLUGINDIR}/kf5/kded)
install(TARGETS browserintegrationreminder DESTINATION ${KDE_INSTALL_PLUGINDIR}/kf${QT_MAJOR_VERSION}/kded)
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment