Commit 905a0ac4 authored by Alexander Lohnau's avatar Alexander Lohnau 💬
Browse files

Silence KRunner deprecation warnings

We need to use this method, because the KPluginSelector can't
handle KPluginMetadata.
parent bccf7e7d
......@@ -132,10 +132,14 @@ SearchConfigModule::SearchConfigModule(QWidget* parent, const QVariantList& args
connect(downloadButton, &KNS3::Button::dialogFinished, this, [this](const KNS3::Entry::List &changedEntries) {
if (!changedEntries.isEmpty()) {
m_pluginSelector->clearPlugins();
QT_WARNING_PUSH
QT_WARNING_DISABLE_CLANG("-Wdeprecated-declarations")
QT_WARNING_DISABLE_GCC("-Wdeprecated-declarations")
m_pluginSelector->addPlugins(Plasma::RunnerManager::listRunnerInfo(),
KPluginSelector::ReadConfigFile,
i18n("Available Plugins"), QString(),
KSharedConfig::openConfig(QStringLiteral("krunnerrc")));
QT_WARNING_POP
}
});
downloadLayout->addStretch();
......@@ -158,10 +162,14 @@ void SearchConfigModule::load()
// Set focus on the pluginselector to pass focus to search bar.
m_pluginSelector->setFocus(Qt::OtherFocusReason);
QT_WARNING_PUSH
QT_WARNING_DISABLE_CLANG("-Wdeprecated-declarations")
QT_WARNING_DISABLE_GCC("-Wdeprecated-declarations")
m_pluginSelector->addPlugins(Plasma::RunnerManager::listRunnerInfo(),
KPluginSelector::ReadConfigFile,
i18n("Available Plugins"), QString(),
config);
QT_WARNING_POP
m_pluginSelector->load();
if(!m_pluginID.isEmpty()){
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment