Commit bcdeaaff authored by Nicolas Fella's avatar Nicolas Fella

Drop outdated version check

We require Qt 5.15 now
parent f836a0e1
......@@ -72,15 +72,8 @@ void Plugin::registerTypes(const char* uri)
Q_UNUSED(jsEngine);
return new MicrophoneIndicator();
});
#if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
qmlRegisterType<QPulseAudio::Client>();
qmlRegisterType<QPulseAudio::Sink>();
qmlRegisterType<QPulseAudio::Source>();
qmlRegisterType<QPulseAudio::VolumeObject>();
#else
qmlRegisterAnonymousType<QPulseAudio::Client>(uri, 1);
qmlRegisterAnonymousType<QPulseAudio::Sink>(uri, 1);
qmlRegisterAnonymousType<QPulseAudio::Source>(uri, 1);
qmlRegisterAnonymousType<QPulseAudio::VolumeObject>(uri, 1);
#endif
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment