Commit 08da0edb authored by Arjen Hiemstra's avatar Arjen Hiemstra
Browse files

Use the new KSysGuard namespace for KSysGuard related targets

Summary:
The targets in the KF5 namespace have been deprecated. This updates the
cmake files to use the new targets.

Test Plan: Builds correctly with most recent libksysguard.

Reviewers: #plasma, mart

Reviewed By: #plasma, mart

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D29630
parent b7472568
......@@ -64,7 +64,7 @@ find_package (KF5NetworkManagerQt ${KF5_DEP_VERSION})
if (KF5NetworkManagerQt_FOUND)
set (HAVE_NETWORKMANAGER TRUE)
endif()
find_package (KF5SysGuard REQUIRED)
find_package (KSysGuard REQUIRED)
find_package(KF5Kirigami2 ${KF5_DEP_VERSION} CONFIG)
set_package_properties(KF5Kirigami2 PROPERTIES
......
......@@ -87,9 +87,9 @@ target_link_libraries (
KF5::I18n
KF5::KIOCore
KF5::KIOWidgets
KF5::SysGuard
KF5::WidgetsAddons
KF5::ProcessCore
KSysGuard::SysGuard
KSysGuard::ProcessCore
)
if (HAVE_NETWORKMANAGER)
target_link_libraries (
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment