Commit ff6ae79c authored by Alexander Lohnau's avatar Alexander Lohnau 💬
Browse files

Drop unneeded QOverload statements

By excluding deprecated code, we no longer need this
parent d6dc89f5
......@@ -36,7 +36,7 @@ void LocaleGeneratorUbuntu::ubuntuInstall(const QStringList &locales)
if (!binaryPath.isEmpty()) {
m_proc->setProgram(binaryPath);
m_proc->setArguments(args);
connect(m_proc, QOverload<int, QProcess::ExitStatus>::of(&QProcess::finished), this, &LocaleGeneratorUbuntu::ubuntuLangCheck);
connect(m_proc, &QProcess::finished, this, &LocaleGeneratorUbuntu::ubuntuLangCheck);
m_proc->start();
} else {
Q_EMIT userHasToGenerateManually(i18nc("@info:warning", "Can't locate executable `check-language-support`"));
......
......@@ -132,7 +132,7 @@ bool LocaleGenHelper::editLocaleGen()
if (!locale_gen.isEmpty()) {
auto *process = new QProcess(this);
process->setProgram(QStringLiteral("locale-gen"));
connect(process, QOverload<int, QProcess::ExitStatus>::of(&QProcess::finished), this, [this, process](int statusCode, QProcess::ExitStatus status) {
connect(process, &QProcess::finished, this, [this, process](int statusCode, QProcess::ExitStatus status) {
handleLocaleGen(statusCode, status, process);
});
process->start();
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment