Members of the KDE Community are recommended to subscribe to the kde-community mailing list at https://mail.kde.org/mailman/listinfo/kde-community to allow them to participate in important discussions and receive other important announcements

Commit b915e5b4 authored by Antonio Rojas's avatar Antonio Rojas

Don't search for and link to libcln when using libqalculate>=2.0

Plasma doesn't use any cln code directly, only via libqalculate. In version 2.0, libqalculate dropped cln in favor of gmp, so the cln dependency
becomes unnecessary.

Differential Revision: https://phabricator.kde.org/D7590
parent b0e8b75b
......@@ -51,7 +51,9 @@ else(QALCULATE_CFLAGS AND QALCULATE_LIBRARIES)
pkg_check_modules(_pc_QALCULATE libqalculate)
endif(QALCULATE_MIN_VERSION)
pkg_check_modules(_pc_CLN cln)
if(${_pc_QALCULATE_VERSION} VERSION_LESS 2.0.0)
pkg_check_modules(_pc_CLN cln)
endif()
if(_pc_QALCULATE_FOUND)
set(QALCULATE_CFLAGS ${_pc_QALCULATE_CFLAGS})
......@@ -73,13 +75,15 @@ else(QALCULATE_CFLAGS AND QALCULATE_LIBRARIES)
${INCLUDE_INSTALL_DIR}
)
find_library(CLN_LIBRARIES
NAMES
cln
PATHS
${_pc_CLN_LIBRARY_DIRS}
${LIB_INSTALL_DIR}
)
if(${_pc_QALCULATE_VERSION} VERSION_LESS 2.0.0)
find_library(CLN_LIBRARIES
NAMES
cln
PATHS
${_pc_CLN_LIBRARY_DIRS}
${LIB_INSTALL_DIR}
)
endif()
else(NOT WIN32)
# XXX: currently no libqalculate on windows
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment