Commit fc9cda5f authored by Friedemann Kleint's avatar Friedemann Kleint

Fix uic/rcc generating outdated export for Qt for Python

Bump version to 6.

Pick-to: dev 6.0
Fixes: QTBUG-89124
Change-Id: Ifcf60552b5b6efb86f79da34da9c34b8efae9fa4
Reviewed-by: default avatarCristian Maureira-Fredes <cristian.maureira-fredes@qt.io>
parent b2ebc226
......@@ -1112,7 +1112,7 @@ bool RCCResourceLibrary::writeHeader()
writeByteArray(QT_VERSION_STR);
writeString("\n");
writeString("# WARNING! All changes made in this file will be lost!\n\n");
writeString("from PySide2 import QtCore\n\n");
writeString("from PySide6 import QtCore\n\n");
break;
case Binary:
writeString("qres");
......
......@@ -39,9 +39,9 @@
QT_BEGIN_NAMESPACE
static const char *standardImports =
R"I(from PySide2.QtCore import *
from PySide2.QtGui import *
from PySide2.QtWidgets import *
R"I(from PySide6.QtCore import *
from PySide6.QtGui import *
from PySide6.QtWidgets import *
)I";
// Change the name of a qrc file "dir/foo.qrc" file to the Python
......@@ -113,17 +113,17 @@ void WriteImports::acceptCustomWidget(DomCustomWidget *node)
return; // Exclude namespaced names (just to make tests pass).
const QString &importModule = qtModuleOf(node);
auto &output = m_uic->output();
// For starting importing PySide2 modules
// For starting importing PySide6 modules
if (!importModule.isEmpty()) {
output << "from ";
if (importModule.startsWith(QLatin1String("Qt")))
output << "PySide2.";
output << "PySide6.";
output << importModule;
if (!className.isEmpty())
output << " import " << className << "\n\n";
} else {
// When the elementHeader is not set, we know it's the continuation
// of a PySide2 import or a normal import of another module.
// of a PySide6 import or a normal import of another module.
if (!node->elementHeader() || node->elementHeader()->text().isEmpty()) {
output << "import " << className << '\n';
} else { // When we do have elementHeader, we know it's a relative import.
......
......@@ -3,7 +3,7 @@
# Created by: The Resource Compiler for Qt version 6.0.0
# WARNING! All changes made in this file will be lost!
from PySide2 import QtCore
from PySide6 import QtCore
qt_resource_data = b"\
\x00\x00\x00#\
......
......@@ -3,7 +3,7 @@
# Created by: The Resource Compiler for Qt version 6.0.0
# WARNING! All changes made in this file will be lost!
from PySide2 import QtCore
from PySide6 import QtCore
qt_resource_data = b"\
\x00\x00\x00#\
......
......@@ -36,9 +36,9 @@
## WARNING! All changes made in this file will be lost when recompiling UI file!
################################################################################
from PySide2.QtCore import *
from PySide2.QtGui import *
from PySide2.QtWidgets import *
from PySide6.QtCore import *
from PySide6.QtGui import *
from PySide6.QtWidgets import *
from gammaview import GammaView
......
......@@ -117,7 +117,7 @@ static QByteArray msgProcessStartFailed(const QString &command, const QString &w
return result.toLocal8Bit();
}
// Locate Python and check whether PySide2 is installed
// Locate Python and check whether PySide6 is installed
static QString locatePython(QTemporaryDir &generatedDir)
{
QString python = QStandardPaths::findExecutable(QLatin1String("python"));
......@@ -128,7 +128,7 @@ static QString locatePython(QTemporaryDir &generatedDir)
QFile importTestFile(generatedDir.filePath(QLatin1String("import_test.py")));
if (!importTestFile.open(QIODevice::WriteOnly| QIODevice::Text))
return QString();
importTestFile.write("import PySide2.QtCore\n");
importTestFile.write("import PySide6.QtCore\n");
importTestFile.close();
QProcess process;
process.start(python, {importTestFile.fileName()});
......@@ -136,7 +136,7 @@ static QString locatePython(QTemporaryDir &generatedDir)
return QString();
if (process.exitStatus() != QProcess::NormalExit || process.exitCode() != 0) {
const QString stdErr = QString::fromLocal8Bit(process.readAllStandardError()).simplified();
qWarning("PySide2 is not installed (%s)", qPrintable(stdErr));
qWarning("PySide6 is not installed (%s)", qPrintable(stdErr));
return QString();
}
importTestFile.remove();
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment