Commit 08ec63f3 authored by Timothée Ravier's avatar Timothée Ravier Committed by Albert Astals Cid
Browse files

CMakeLists.txt: Set project VERSION for release tools

parent 46990751
cmake_minimum_required (VERSION 3.0)
project(kcachegrind)
# KDE Application Version, managed by release script
set(RELEASE_SERVICE_VERSION_MAJOR "20")
set(RELEASE_SERVICE_VERSION_MINOR "07")
set(RELEASE_SERVICE_VERSION_MICRO "70")
set(KCACHEGRIND_VERSION ${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO})
project(kcachegrind VERSION ${KCACHEGRIND_VERSION})
# minimal requirements
set (QT_MIN_VERSION "5.11.0")
......@@ -41,8 +47,6 @@ add_definitions(
-DQT_NO_SIGNALS_SLOTS_KEYWORDS
)
set( KCACHEGRIND_VERSION "0.8.0kde")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/version.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/version.h )
IF(NOT WIN32)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment