Bump min deps to Qt 5.9 & KF 5.53

parent 50a96df9
cmake_minimum_required(VERSION 3.0)
find_package(ECM 5.14 REQUIRED NO_MODULE)
set(QT_MIN_VERSION "5.9.0")
set(KF_MIN_VERSION "5.53.0")
find_package(ECM ${KF_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
include(FeatureSummary)
......@@ -11,7 +14,7 @@ include(KDECompilerSettings NO_POLICY_SCOPE)
include(ECMQtDeclareLoggingCategory)
# Required for ki18n_install(po) added on tarball generation
find_package(KF5 REQUIRED COMPONENTS I18n)
find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS I18n)
add_subdirectory(kpartloader)
add_subdirectory(kuiviewer)
......
project(kpartloader)
########### kpartloader ###############
set(QT_MIN_VERSION "5.5.0")
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE
COMPONENTS
Core
)
find_package(KF5 REQUIRED
find_package(KF5 ${KF_MIN_VERSION} REQUIRED
COMPONENTS
CoreAddons
Parts
......
project(kuiviewer)
set(QT_MIN_VERSION "5.5.0")
include(ECMAddAppIcon)
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE
......@@ -11,7 +9,7 @@ find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE
UiTools
)
find_package(KF5 REQUIRED
find_package(KF5 ${KF_MIN_VERSION} REQUIRED
COMPONENTS
CoreAddons
KIO
......@@ -20,7 +18,7 @@ find_package(KF5 REQUIRED
add_definitions(
-DQT_DEPRECATED_WARNINGS
-DQT_DISABLE_DEPRECATED_BEFORE=0x050500
-DQT_DISABLE_DEPRECATED_BEFORE=0x050900
-DQT_NO_SIGNALS_SLOTS_KEYWORDS
-DQT_STRICT_ITERATORS
-DQT_USE_QSTRINGBUILDER
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment