Commit 6f0305bb authored by Friedrich W. H. Kossebau's avatar Friedrich W. H. Kossebau
Browse files

Bump min KF deps to 5.85

parent c5cfcde6
......@@ -13,7 +13,7 @@ set(KOMPARE_VERSION "${KOMPARE_BASE_VERSION}.${RELEASE_SERVICE_COMPACT_VERSION}"
project(Kompare VERSION ${KOMPARE_VERSION})
set(QT_MIN_VERSION "5.15.0")
set(KF_MIN_VERSION "5.83.0")
set(KF_MIN_VERSION "5.85.0")
find_package(ECM ${KF5_MIN_VERSION} NO_MODULE REQUIRED)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH})
......@@ -57,22 +57,16 @@ set(KOMPARE_LIB_VERSION 5)
set(KOMPARE_LIB_SOVERSION 5)
add_definitions(
-DQT_DEPRECATED_WARNINGS
-DQT_DISABLE_DEPRECATED_BEFORE=0x050F00
-DQT_DEPRECATED_WARNINGS_SINCE=0x060000
-DQT_NO_KEYWORDS
-DQT_STRICT_ITERATORS
-DQT_USE_QSTRINGBUILDER
-DQT_NO_CAST_TO_ASCII
-DQT_NO_CAST_FROM_ASCII
-DQT_NO_CAST_FROM_BYTEARRAY
# -DQT_NO_URL_CAST_FROM_STRING
-DQT_NO_FOREACH
-DQT_NO_NARROWING_CONVERSIONS_IN_CONNECT
-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055200
-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055400
-DKSERVICE_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055100 # KMimeTypeTrader deprecated in 5.82
-DKF_DEPRECATED_WARNINGS_SINCE=0x060000
)
# added by KDE_COMPILERSETTINGS_LEVEL 5.85.0
remove_definitions(
-DQT_NO_URL_CAST_FROM_STRING
)
add_subdirectory(doc)
add_subdirectory(src)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment