Members of the KDE Community are recommended to subscribe to the kde-community mailing list at https://mail.kde.org/mailman/listinfo/kde-community to allow them to participate in important discussions and receive other important announcements

Use KF5_MIN_VERSION also for ECM, now that it is released together

parent 20926ba8
......@@ -2,8 +2,10 @@ cmake_minimum_required(VERSION 3.0)
project(kompare)
set(ECM_MIN_VERSION "5.35.0")
find_package(ECM ${ECM_MIN_VERSION} NO_MODULE REQUIRED)
set(QT_MIN_VERSION "5.5.0")
set(KF5_MIN_VERSION "5.35.0")
find_package(ECM ${KF5_MIN_VERSION} NO_MODULE REQUIRED)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH})
include(FeatureSummary)
......@@ -15,14 +17,12 @@ include(GenerateExportHeader)
include(ECMAddAppIcon)
include(ECMQtDeclareLoggingCategory)
set(QT_MIN_VERSION "5.5.0")
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED COMPONENTS
Core
PrintSupport
Widgets
)
set(KF5_MIN_VERSION "5.28.0")
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
CoreAddons
Codecs
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment