Commit 74c9c2d9 authored by Oliver Kellogg's avatar Oliver Kellogg
Browse files

umbrello/umldoc.cpp

- In function loadFromXMI1 case !versionString.isEmpty() lower version
  requirement to 1.0.
  This change restores loading of files produced the Unisys.JCR.1 Rose
  to XMI converter, see https://bugs.kde.org/attachment.cgi?id=8666

CCBUG: 56184
parent d1ec3e56
...@@ -2324,7 +2324,7 @@ bool UMLDoc::loadFromXMI1(QIODevice & file, short encode) ...@@ -2324,7 +2324,7 @@ bool UMLDoc::loadFromXMI1(QIODevice & file, short encode)
versionString = root.attribute(QLatin1String("xmi:version")); versionString = root.attribute(QLatin1String("xmi:version"));
if (! versionString.isEmpty()) { if (! versionString.isEmpty()) {
double version = versionString.toDouble(); double version = versionString.toDouble();
if (version < 1.1) { if (version < 1.0) {
QString error = i18n("Unsupported xmi file version: %1", versionString); QString error = i18n("Unsupported xmi file version: %1", versionString);
m_d->errors << error; m_d->errors << error;
DEBUG(DBG_SRC) << error; DEBUG(DBG_SRC) << error;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment