Commit d75068ed authored by Ben Cooksley's avatar Ben Cooksley

Install requirements for running the sftp upload script from the CI tooling

parent db0fe910
......@@ -13,6 +13,9 @@ RUN apt-get update && apt-get upgrade -y && apt-get install -y openssh-server op
# Craft and Craftmaster need Python 3.6 at a minimum
RUN add-apt-repository ppa:deadsnakes/ppa && apt-get update && apt-get install -y python3.6
# The CI Tooling requires YAML and XML support in Python, along with Paramiko
RUN apt-get install -y python3-yaml python3-lxml python3-paramiko
# Enable the source repositories
RUN cat /etc/apt/sources.list | sed -e 's,# deb-src,deb-src,' > /etc/apt/sources.list.new && mv /etc/apt/sources.list.new /etc/apt/sources.list && apt-get update
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment