Commit b04ca519 authored by Aleix Pol Gonzalez's avatar Aleix Pol Gonzalez 🐧

android: force qmakespec when building native qtdeclarative

Otherwise it's built for ARM
parent f4eef269
......@@ -129,7 +129,7 @@ RUN cd && git clone git://code.qt.io/qt/qtbase.git --single-branch --branch ${QT
# QtQml Needed for native tooling (ki18n)
RUN cd && git clone git://code.qt.io/qt/qtdeclarative.git --single-branch --branch ${QT_TAG} && cd qtdeclarative \
&& qmake . && make -j`nproc` && make install && rm -rf ~/qtdeclarative
&& QMAKESPEC=linux-g++ /opt/nativetooling/bin/qmake . && make -j`nproc` && make install && rm -rf ~/qtdeclarative
# Replace androiddeployqt with dev, which has a bunch of patches we need (at least until Qt 5.12)
RUN cd && mkdir androiddeployqt && cd androiddeployqt \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment