Require C++17

Not only does C++17 bring many nice things, it also will be required
with Qt6.

Many KDE projects already require 17 without issues.
1 job for master
Status Job ID Name Coverage
  Build
canceled #91249
linux kf5-qt5 qt5.15