Members of the KDE Community are recommended to subscribe to the kde-community mailing list at https://mail.kde.org/mailman/listinfo/kde-community to allow them to participate in important discussions and receive other important announcements

Commit cd90c043 authored by Heiko Becker's avatar Heiko Becker 🎸

Use CMakePackageConfigHelpers instead of the ECM variant

Summary:
dolphin already requires cmake >= 3.0, which includes the macro.
Also make sure to include the CMakeFindDependencyMacro.

Reviewers: #dolphin

Differential Revision: https://phabricator.kde.org/D9091
parent 99883ca8
......@@ -17,7 +17,7 @@ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake)
include(ECMSetupVersion)
include(ECMGenerateHeaders)
include(ECMPackageConfigHelpers)
include(CMakePackageConfigHelpers)
include(GenerateExportHeader)
include(FeatureSummary)
include(KDEInstallDirs)
......@@ -108,7 +108,7 @@ add_subdirectory(doc)
# CMake files
set(CMAKECONFIG_INSTALL_DIR "${KDE_INSTALL_CMAKEPACKAGEDIR}/DolphinVcs")
ecm_configure_package_config_file(
configure_package_config_file(
"${CMAKE_CURRENT_SOURCE_DIR}/DolphinVcsConfig.cmake.in"
"${CMAKE_CURRENT_BINARY_DIR}/DolphinVcsConfig.cmake"
INSTALL_DESTINATION ${CMAKECONFIG_INSTALL_DIR}
......
@PACKAGE_INIT@
include(CMakeFindDependencyMacro)
find_dependency(Qt5Widgets)
find_dependency(KF5KIO)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment