Commit 26fdfac2 authored by Martin Flöser's avatar Martin Flöser
Browse files

Do not block OpenGL 2 when build for gles due to driver recommendation

Let's assume a user knows what she is doing when she selects kwin_gles
instead of kwin. Also in gles there is no fallback to OpenGL 1 possible
so blocking is not the proper solution in the first place.

BUG: 311712
FIXED-IN: 4.10 RC 2
REVIEW: 107824
parent 35279c14
......@@ -462,7 +462,9 @@ bool SceneOpenGL2::supported(OpenGLBackend *backend)
}
if (GLPlatform::instance()->recommendedCompositor() < OpenGL2Compositing) {
kDebug(1212) << "Driver does not recommend OpenGL 2 compositing";
#ifndef KWIN_HAVE_OPENGLES
return false;
#endif
}
if (options->isGlLegacy()) {
kDebug(1212) << "OpenGL 2 disabled by config option";
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment