Commit 8a60d384 authored by Laurent Montel's avatar Laurent Montel 😁

Don't use editVacaction signal which is not exist. Don't create multi connection

parent ca18e95c
...@@ -146,7 +146,7 @@ else() ...@@ -146,7 +146,7 @@ else()
set(CALENDARSUPPORT_LIB_VERSION_LIB "5.2.80") set(CALENDARSUPPORT_LIB_VERSION_LIB "5.2.80")
set(EVENTVIEW_LIB_VERSION_LIB "5.2.80") set(EVENTVIEW_LIB_VERSION_LIB "5.2.80")
set(KDGANTT2_LIB_VERSION_LIB "5.2.80") set(KDGANTT2_LIB_VERSION_LIB "5.2.80")
set(LIBKSIEVE_LIB_VERSION_LIB "5.2.80") set(LIBKSIEVE_LIB_VERSION_LIB "5.2.81")
find_package(KF5WebEngineViewer ${MESSAGELIB_LIB_VERSION_LIB} CONFIG REQUIRED) find_package(KF5WebEngineViewer ${MESSAGELIB_LIB_VERSION_LIB} CONFIG REQUIRED)
set(WEBENGINE_TYPE "QtWebEngine") set(WEBENGINE_TYPE "QtWebEngine")
......
...@@ -68,7 +68,7 @@ if(${CMAKE_SOURCE_DIR} STREQUAL ${kmail_SOURCE_DIR}) ...@@ -68,7 +68,7 @@ if(${CMAKE_SOURCE_DIR} STREQUAL ${kmail_SOURCE_DIR})
set(LIBKLEO_LIB_VERSION_LIB "5.2.80") set(LIBKLEO_LIB_VERSION_LIB "5.2.80")
set(PIMCOMMON_LIB_VERSION_LIB "5.2.80") set(PIMCOMMON_LIB_VERSION_LIB "5.2.80")
set(LIBKDEPIM_LIB_VERSION_LIB "5.2.80") set(LIBKDEPIM_LIB_VERSION_LIB "5.2.80")
set(LIBKSIEVE_LIB_VERSION_LIB "5.2.80") set(LIBKSIEVE_LIB_VERSION_LIB "5.2.81")
find_package(KF5WebEngineViewer ${MESSAGELIB_LIB_VERSION_LIB} CONFIG REQUIRED) find_package(KF5WebEngineViewer ${MESSAGELIB_LIB_VERSION_LIB} CONFIG REQUIRED)
set(WEBENGINE_TYPE "QtWebEngine") set(WEBENGINE_TYPE "QtWebEngine")
......
...@@ -250,6 +250,7 @@ KMMainWidget::KMMainWidget(QWidget *parent, KXMLGUIClient *aGUIClient, ...@@ -250,6 +250,7 @@ KMMainWidget::KMMainWidget(QWidget *parent, KXMLGUIClient *aGUIClient,
Akonadi::ControlGui::widgetNeedsAkonadi(this); Akonadi::ControlGui::widgetNeedsAkonadi(this);
mFavoritesModel = Q_NULLPTR; mFavoritesModel = Q_NULLPTR;
mVacationManager = new KSieveUi::VacationManager(this); mVacationManager = new KSieveUi::VacationManager(this);
connect(mVacationManager, SIGNAL(updateVacationScriptStatus(bool,QString)), SLOT(updateVacationScriptStatus(bool,QString)));
mToolbarActionSeparator = new QAction(this); mToolbarActionSeparator = new QAction(this);
mToolbarActionSeparator->setSeparator(true); mToolbarActionSeparator->setSeparator(true);
...@@ -2232,8 +2233,6 @@ void KMMainWidget::slotCheckVacation() ...@@ -2232,8 +2233,6 @@ void KMMainWidget::slotCheckVacation()
} }
mVacationManager->checkVacation(); mVacationManager->checkVacation();
connect(mVacationManager, SIGNAL(updateVacationScriptStatus(bool,QString)), SLOT(updateVacationScriptStatus(bool,QString)));
connect(mVacationManager, &KSieveUi::VacationManager::editVacation, this, &KMMainWidget::slotEditCurrentVacation);
} }
void KMMainWidget::slotEditCurrentVacation() void KMMainWidget::slotEditCurrentVacation()
......
...@@ -43,7 +43,7 @@ if(${CMAKE_SOURCE_DIR} STREQUAL ${sieveeditor_SOURCE_DIR}) ...@@ -43,7 +43,7 @@ if(${CMAKE_SOURCE_DIR} STREQUAL ${sieveeditor_SOURCE_DIR})
set(MESSAGELIB_LIB_VERSION_LIB "5.2.90") set(MESSAGELIB_LIB_VERSION_LIB "5.2.90")
set(PIMCOMMON_LIB_VERSION_LIB "5.2.80") set(PIMCOMMON_LIB_VERSION_LIB "5.2.80")
set(LIBKSIEVE_LIB_VERSION_LIB "5.2.80") set(LIBKSIEVE_LIB_VERSION_LIB "5.2.81")
set(QT_REQUIRED_VERSION "5.6.0") set(QT_REQUIRED_VERSION "5.6.0")
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets Network Test) find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets Network Test)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment