Commit 6ee40080 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Use KPluginMetaData::findPlugins when we use kf5-5.86

parent 54fa13a2
Pipeline #92405 passed with stage
in 2 minutes and 32 seconds
......@@ -4,9 +4,9 @@
SPDX-License-Identifier: BSD-2-Clause
*/
#include "kcoreaddons_version.h"
#include <KPluginLoader>
#include <KPluginMetaData>
#include <QTest>
class MetaDataTest : public QObject
......@@ -26,7 +26,11 @@ private:
void MetaDataTest::initTestCase()
{
#if KCOREADDONS_VERSION < QT_VERSION_CHECK(5, 86, 0)
m_plugins = KPluginLoader::findPlugins(QStringLiteral("kerfuffle"));
#else
m_plugins = KPluginMetaData::findPlugins(QStringLiteral("kerfuffle"));
#endif
}
// If a plugin has invalid JSON metadata (e.g. an extra comma somewhere)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment