Commit a9de72ee authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

We depend against 5.71.0

parent 37d5cc4c
...@@ -80,11 +80,7 @@ endif (WITH_TEST_COVERAGE) ...@@ -80,11 +80,7 @@ endif (WITH_TEST_COVERAGE)
set(SUPPORTED_ARK_MIMETYPES "") set(SUPPORTED_ARK_MIMETYPES "")
add_definitions(-DTRANSLATION_DOMAIN="ark") add_definitions(-DTRANSLATION_DOMAIN="ark")
# Until kf5 5.56 kconfig had some header which used Q_FOREACH add_definitions(-DQT_NO_FOREACH)
# Q_FOREACH will be deprecated/removed in qt6. With QT_NO_FOREACH we prepare the migration to qt6.
if (KF5Config_VERSION VERSION_GREATER "5.56.0")
add_definitions(-DQT_NO_FOREACH)
endif()
add_subdirectory(plugins) add_subdirectory(plugins)
add_subdirectory(kerfuffle) add_subdirectory(kerfuffle)
...@@ -99,10 +95,6 @@ endif() ...@@ -99,10 +95,6 @@ endif()
ki18n_install(po) ki18n_install(po)
kdoctools_install(po) kdoctools_install(po)
if (NOT ECM_VERSION VERSION_LESS "5.59.0") install(FILES ark.categories DESTINATION ${KDE_INSTALL_LOGGINGCATEGORIESDIR})
install(FILES ark.categories DESTINATION ${KDE_INSTALL_LOGGINGCATEGORIESDIR})
else()
install(FILES ark.categories DESTINATION ${KDE_INSTALL_CONFDIR})
endif()
feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES) feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment