Commit 918cb63a authored by Aleix Pol Gonzalez's avatar Aleix Pol Gonzalez 🐧 Committed by Antonio Rojas
Browse files

Revert "Make it compile against last qt5.15 without deprecated method"

This reverts commit 9c901d16.
parent 8f740c73
......@@ -85,13 +85,9 @@ CreateDialog::CreateDialog(QWidget *parent,
connect(m_ui->buttonBox, &QDialogButtonBox::accepted, this, &QDialog::accept);
connect(m_ui->buttonBox, &QDialogButtonBox::rejected, this, &QDialog::reject);
connect(this, &QDialog::accepted, this, &CreateDialog::slotUpdateDefaultMimeType);
#if QT_VERSION < QT_VERSION_CHECK(5, 15, 0)
connect(m_ui->mimeComboBox, QOverload<int>::of(&QComboBox::currentIndexChanged), this, &CreateDialog::slotUpdateWidgets);
connect(m_ui->mimeComboBox, QOverload<int>::of(&QComboBox::currentIndexChanged), this, &CreateDialog::slotUpdateFilenameExtension);
#else
connect(m_ui->mimeComboBox, QOverload<int, const QString &>::of(&QComboBox::currentIndexChanged), this, &CreateDialog::slotUpdateWidgets);
connect(m_ui->mimeComboBox, QOverload<int, const QString &>::of(&QComboBox::currentIndexChanged), this, &CreateDialog::slotUpdateFilenameExtension);
#endif
m_vlayout->addWidget(m_ui);
m_ui->optionsWidget->setMimeType(currentMimeType());
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment