Commit a2a17102 authored by Elvis Angelaccio's avatar Elvis Angelaccio

Find and link Qt5 Concurrent module

Qt5 Concurrent is a separate module, so we need to find it and link to it.
This way we can #include <QtConcurrentRun> without hardcoding the module name.

Most distros include this module in their "basic" qt5 package (e.g. qt5-base on
Archlinux), so this is not really a bug.
parent cbea04af
......@@ -35,6 +35,7 @@ ecm_setup_version(${ARK_VERSION}
SOVERSION ${ARK_VERSION_MAJOR})
find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED
Concurrent
Core
Gui
Widgets)
......
......@@ -45,10 +45,10 @@ PUBLIC
KF5::I18n
KF5::WidgetsAddons
PRIVATE
Qt5::Concurrent
KF5::KIOCore
KF5::KIOWidgets
KF5::KIOFileWidgets
)
set_target_properties(kerfuffle PROPERTIES VERSION ${KERFUFFLE_VERSION_STRING} SOVERSION ${KERFUFFLE_SOVERSION})
......
......@@ -29,7 +29,7 @@
#include "ark_debug.h"
#include "ui_propertiesdialog.h"
#include <QtConcurrent/QtConcurrentRun>
#include <QtConcurrentRun>
#include <QDateTime>
#include <QFileInfo>
#include <QFontDatabase>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment