Commit ebae4b1c authored by Elvis Angelaccio's avatar Elvis Angelaccio

Remove unnecessary version check

Previous commit doesn't do what it says, as the check happens at
build-time and not at runtime. So word-wrapping would still be disabled
if one upgrades to KF 5.29 without rebuilding Ark.

We can just unconditionnaly enable word-wrapping, since KF 5.29 will be
released almost together with Applications 16.12
parent ae6ce265
......@@ -33,7 +33,6 @@
#include <KColorScheme>
#include <KPluginMetaData>
#include <kwidgetsaddons_version.h>
#include <QMimeDatabase>
......@@ -60,10 +59,7 @@ CompressionOptionsWidget::CompressionOptionsWidget(QWidget *parent,
volumeSizeSpinbox->setValue(static_cast<double>(m_opts.volumeSize()) / 1024);
}
// KWidgetsAddons 5.29 fixes KMessageWidget word-wrapping.
if (KWIDGETSADDONS_VERSION >= QT_VERSION_CHECK(5, 29, 0)) {
warningMsgWidget->setWordWrap(true);
}
warningMsgWidget->setWordWrap(true);
}
CompressionOptions CompressionOptionsWidget::commpressionOptions() const
......
......@@ -56,7 +56,6 @@
#include <KStandardGuiItem>
#include <KToggleAction>
#include <KLocalizedString>
#include <kwidgetsaddons_version.h>
#include <KXMLGUIFactory>
#include <QAction>
......@@ -124,10 +123,7 @@ Part::Part(QWidget *parentWidget, QObject *parent, const QVariantList& args)
m_commentBox->setLayout(vbox);
m_messageWidget = new KMessageWidget(parentWidget);
// KWidgetsAddons 5.29 fixes KMessageWidget word-wrapping.
if (KWIDGETSADDONS_VERSION >= QT_VERSION_CHECK(5, 29, 0)) {
m_messageWidget->setWordWrap(true);
}
m_messageWidget->setWordWrap(true);
m_messageWidget->hide();
m_commentMsgWidget = new KMessageWidget();
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment