Commit 296d077b authored by Harald Sitter's avatar Harald Sitter 🏳️‍🌈
Browse files

codify qml dependencies

parent 232c9190
......@@ -37,6 +37,7 @@ include(ECMQtDeclareLoggingCategory)
include(ECMDeprecationSettings)
include(KDEClangFormat)
include(KDEGitCommitHooks)
include(ECMFindQmlModule)
find_package(Qt${QT_MAJOR_VERSION} ${QT_REQUIRED_VERSION} CONFIG REQUIRED Core Widgets Svg Quick)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
......@@ -48,6 +49,9 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
)
find_package(KF5DocTools) # Optional, not needed on Windows for example.
ecm_find_qmlmodule(org.kde.kirigami 2.19)
ecm_find_qmlmodule(org.kde.quickcharts 1.0)
add_definitions(-DTRANSLATION_DOMAIN=\"filelight\")
ecm_set_disabled_deprecation_versions(QT 5.15.2
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment