Commit 4a157701 authored by Kåre Särs's avatar Kåre Särs

Remove obsolete QScript includes from CMake files

Differential Revision: https://phabricator.kde.org/D9291
parent ab275338
......@@ -32,7 +32,7 @@ include (CheckFunctionExists)
include(KDEInstallDirs)
include(KDECMakeSettings)
find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED Core DBus Widgets Script Sql)
find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED Core DBus Widgets Sql)
if(BUILD_TESTING)
find_package(Qt5Test ${QT_MIN_VERSION} CONFIG REQUIRED)
......
......@@ -32,6 +32,6 @@ kcoreaddons_desktop_to_json (katesqlplugin katesql.desktop)
target_link_libraries(katesqlplugin
KF5::TextEditor
KF5::Parts KF5::I18n KF5::Wallet
Qt5::Script Qt5::Sql KF5::ItemViews KF5::IconThemes)
Qt5::Sql KF5::ItemViews KF5::IconThemes)
install(TARGETS katesqlplugin DESTINATION ${PLUGIN_INSTALL_DIR}/ktexteditor )
......@@ -38,7 +38,7 @@ target_link_libraries(kateprojectplugin
KF5::TextEditor
KF5::Parts KF5::I18n
KF5::GuiAddons
Qt5::Script KF5::ItemViews KF5::ItemModels KF5::IconThemes KF5::ThreadWeaver
KF5::ItemViews KF5::ItemModels KF5::IconThemes KF5::ThreadWeaver
KF5::NewStuff # For KMoreTools
)
......
......@@ -19,6 +19,6 @@ kcoreaddons_desktop_to_json (katesearchplugin katesearch.desktop)
target_link_libraries(katesearchplugin
KF5::TextEditor
KF5::Parts KF5::I18n KF5::IconThemes
Qt5::Script KF5::ItemViews)
KF5::ItemViews)
install(TARGETS katesearchplugin DESTINATION ${PLUGIN_INSTALL_DIR}/ktexteditor)
......@@ -29,6 +29,6 @@ kcoreaddons_desktop_to_json (katesnippetsplugin katesnippetsplugin.desktop)
target_link_libraries(katesnippetsplugin
KF5::TextEditor
KF5::Parts KF5::I18n
KF5::NewStuff Qt5::Script KF5::ItemViews KF5::IconThemes)
KF5::NewStuff KF5::ItemViews KF5::IconThemes)
install(TARGETS katesnippetsplugin DESTINATION ${PLUGIN_INSTALL_DIR}/ktexteditor )
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment