Commit 14b3d227 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

GIt_SILENT: It's not necessary

parent f73290c8
Pipeline #74819 canceled with stage
......@@ -28,7 +28,6 @@ include(KDEGitCommitHooks)
include(ECMAddAppIcon)
include(ECMInstallIcons)
include(KDEInstallDirs)
set(KDE_COMPILERSETTINGS_LEVEL 5.85.0)
include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
include(KDECMakeSettings)
include(ECMAddTests)
......
  • Also please do not ignore that using KDEFrameworkCompilerSettings when requiring ECM >= 5.85 is not supported outside from KDE Frameworks modules. Things had been kept working so far, due to the existing repurposing of KDEFrameworkCompilerSettings outside of KDE Frameworks modules. The warning on https://api.kde.org/ecm/kde-module/KDEFrameworkCompilerSettings.html is for a reason, allow me to cite it here:

    Warning: Do not use this module for software which is not part of KDE-Frameworks. There is no guarantee for backward-compatibility in newer versions.

    Now we have the settings levels in KDECompilerSettings to achieve the same goal, and there is no more reason for the repurposing of KDEFrameworkCompilerSettings over using the supported and documented official way.

    Please read again https://marc.info/?l=kde-devel&m=162893561025502&w=2 things there are not just meant as recommendation.

Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment