Commit f73290c8 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Time to increase version

parent 37eaded9
Pipeline #74816 canceled with stage
...@@ -7,7 +7,7 @@ cmake_minimum_required (VERSION 3.16.0 FATAL_ERROR) ...@@ -7,7 +7,7 @@ cmake_minimum_required (VERSION 3.16.0 FATAL_ERROR)
project(kdebugsettings VERSION ${RELEASE_SERVICE_VERSION}) project(kdebugsettings VERSION ${RELEASE_SERVICE_VERSION})
set(QT_MIN_VERSION "5.15.0") set(QT_MIN_VERSION "5.15.0")
set(KF5_MIN_VERSION "5.84.0") set(KF5_MIN_VERSION "5.85.0")
set(ECM_VERSION ${KF5_MIN_VERSION}) set(ECM_VERSION ${KF5_MIN_VERSION})
find_package(ECM ${ECM_VERSION} REQUIRED NO_MODULE) find_package(ECM ${ECM_VERSION} REQUIRED NO_MODULE)
...@@ -28,6 +28,7 @@ include(KDEGitCommitHooks) ...@@ -28,6 +28,7 @@ include(KDEGitCommitHooks)
include(ECMAddAppIcon) include(ECMAddAppIcon)
include(ECMInstallIcons) include(ECMInstallIcons)
include(KDEInstallDirs) include(KDEInstallDirs)
set(KDE_COMPILERSETTINGS_LEVEL 5.85.0)
include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE) include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
include(KDECMakeSettings) include(KDECMakeSettings)
include(ECMAddTests) include(ECMAddTests)
......
  • @mlaurent Hi. The combination of KDE_COMPILERSETTINGS_LEVEL and KDEFrameworkCompilerSettings is not supported when requiring ECM > 5.84, things might break in lots of ways.

    Please switch to using KDECompilerSettings in such cases now, which will bring all the more strict settings in a supported way now.

  • And looking at the CMakeLists.txt a bit more, other things which need to/ or could be twisted:

Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment