Commit 02db28ad authored by Ahmad Samir's avatar Ahmad Samir
Browse files

Adjust buildsystem for Qt6

parent ba510444
......@@ -24,7 +24,7 @@ include(FeatureSummary)
# Build dependencies
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS TextWidgets Notifications GuiAddons IconThemes WindowSystem KIO DBusAddons)
find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS DBus)
find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS DBus)
find_package(X11)
......
......@@ -39,7 +39,7 @@ install(FILES org.kde.kdialog.ProgressDialog.xml DESTINATION ${KDE_INSTALL_DBUSI
add_executable(kdialog_progress_helper)
qt5_add_dbus_adaptor(progressdialog_dbus_adaptor_SRCS
qt_add_dbus_adaptor(progressdialog_dbus_adaptor_SRCS
org.kde.kdialog.ProgressDialog.xml progressdialog.h ProgressDialog
)
......@@ -55,7 +55,7 @@ target_sources(kdialog_progress_helper PRIVATE
target_link_libraries(kdialog_progress_helper
KF5::DBusAddons
KF5::I18n
Qt5::Widgets
Qt::Widgets
)
if (HAVE_X11)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment