Commit f276273a authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Make it compiles against qt5.15 (endl other other use Qt:: namespace now)

parent a82894e6
...@@ -429,7 +429,13 @@ bool FloppyData::setInitialDevice(const QString& dev) ...@@ -429,7 +429,13 @@ bool FloppyData::setInitialDevice(const QString& dev)
QDBusInterface mediamanager( QStringLiteral( "org.kde.kded" ), QStringLiteral( "/modules/mediamanager" ), QStringLiteral( "org.kde.MediaManager" ) ); QDBusInterface mediamanager( QStringLiteral( "org.kde.kded" ), QStringLiteral( "/modules/mediamanager" ), QStringLiteral( "org.kde.MediaManager" ) );
QDBusReply<QStringList> reply = mediamanager.call( QStringLiteral( "properties" ), name ); QDBusReply<QStringList> reply = mediamanager.call( QStringLiteral( "properties" ), name );
if (!reply.isValid()) { if (!reply.isValid()) {
qCritical() << "Invalid reply from mediamanager" << endl; qCritical() << "Invalid reply from mediamanager"
#if (QT_VERSION < QT_VERSION_CHECK(5, 15, 0))
<< endl
#else
<< Qt::endl
#endif
;
} else { } else {
QStringList properties = reply; QStringList properties = reply;
newDevice = properties[5]; newDevice = properties[5];
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment