Commit 59f54e46 authored by Kurt Hindenburg's avatar Kurt Hindenburg
Browse files

Use C++17

There was support for bumping this to 14 or 17 earlier this year.
I'll check before 21.04 is released on how much code actually needs 17.
All modern OS distros should have a C++17 compiler.
parent fcdcae68
......@@ -70,7 +70,7 @@ add_definitions(
-DQT_NO_URL_CAST_FROM_STRING
)
set(CMAKE_CXX_STANDARD 11)
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment