Commit 3e6ea0c6 authored by Heiko Becker's avatar Heiko Becker 🎸

Don't implicitly require KF5 5.57.0

be7b2b63 added
"add_definitions(-DQT_NO_FOREACH)" but kconfig < 5.57 still uses
it and thus building ktimer with a lower version fails.
parent 44c5d24a
......@@ -34,7 +34,9 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
add_definitions(-DQT_NO_NARROWING_CONVERSIONS_IN_CONNECT)
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x060000)
add_definitions(-DQT_NO_FOREACH)
if (${KF5Config_VERSION} STRGREATER "5.56.0")
add_definitions(-DQT_NO_FOREACH)
endif()
configure_file(config-ktimer.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-ktimer.h)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment