Commit 6f7ae97b authored by Volker Krause's avatar Volker Krause
Browse files

Do not use future versions for disabling deprecated API in stable branches

parent beab7134
......@@ -52,8 +52,8 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
Crash
)
if (EXISTS "${CMAKE_SOURCE_DIR}/.git")
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x060000)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x060000)
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050D00)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054000)
endif()
if (KF5Config_VERSION VERSION_GREATER "5.56.0")
add_definitions(-DQT_NO_FOREACH)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment