CMakeLists.txt 4.65 KB
Newer Older
1
cmake_minimum_required(VERSION 2.8.11.1)
2

3 4
project( okteta )

5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
#copy the way kde-workspace does it

set(QT_MIN_VERSION "5.2.0")
find_package(ECM 0.0.8 REQUIRED NO_MODULE)
include(CMakePackageConfigHelpers)
# where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH})

find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Widgets Script ScriptTools)
find_package(Qt5Transitional MODULE)
#workaround wrong dirs being used

add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0) #allow deprecated functions for now


find_package(kdeqt5staging REQUIRED NO_MODULE)
# Load CMake, Compiler and InstallDirs settings from KF5 and the following are already somewhat "done" tier1/tier2 libs from kdelibs:
find_package(KF5 MODULE REQUIRED COMPONENTS CMake Compiler InstallDirs
23 24
                                            KWidgetsAddons KCoreAddons KConfig KI18n KGuiAddons KDBusAddons KService ItemViews KAuth KCodecs
                                            KConfigWidgets KWindowSystem KNotifications KIconThemes Sonnet KCompletion
25
                                            KTextWidgets XmlGui KDBusAddons KCrash KArchive ItemModels KJobWidgets Solid KWallet KJS
26
                                            KIO KUnitConversion KDE4Attic
27 28
                                            )

Alex Richardson's avatar
Alex Richardson committed
29
if( UNIX )
30
  set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -std=c++0x -fno-rtti")
Alex Richardson's avatar
Alex Richardson committed
31 32
endif()

33 34 35 36 37 38
# needed for set_package_properties macro
find_package(LibAttica REQUIRED NO_MODULE ) #somehow this is not searched for
find_package(KDELibs4 REQUIRED NO_MODULE) #needed for KDE4Support
find_package(KDE4Support REQUIRED NO_MODULE)

set(CMAKE_POSITION_INDEPENDENT_CODE ON) #this is needed since it is apparently not set by Qt5Config.cmake
39

40
set( CMAKE_INCLUDE_CURRENT_DIR ON )
41 42 43
set( CMAKE_AUTOMOC TRUE )
include_directories( ${KDE4_INCLUDES} )

44 45 46 47 48 49
include(FeatureSummary)

find_package(QCA2)
set_package_properties(QCA2 PROPERTIES DESCRIPTION "Qt Cryptographic Architecture"
                       URL "http://delta.affinix.com/qca" TYPE OPTIONAL
                       PURPOSE "Needed for most of the algorithms of the checksum tool")
50

51 52 53 54 55 56 57 58 59 60 61 62 63 64
# control build scope
# TODO: examples and templates not internal need headers and libs as installed
# so they can be only build after the installation was done
# How to handle this best, as in: they are per default always build after an install?
# set( KASTEN_BUILD_EXAMPLES  NOT OMIT_EXAMPLES )
# set( OKTETA_BUILD_EXAMPLES  NOT OMIT_EXAMPLES )
set( KASTEN_BUILD_INTERNAL_EXAMPLES  NOT OMIT_INTERNAL_EXAMPLES )
set( OKTETA_BUILD_INTERNAL_EXAMPLES  NOT OMIT_INTERNAL_EXAMPLES )

# set( KASTEN_BUILD_TEMPLATES NOT SKIPTEMPLATES )
# set( OKTETA_BUILD_TEMPLATES NOT SKIPTEMPLATES )
set( KASTEN_BUILD_INTERNAL_TEMPLATES NOT OMIT_INTERNAL_TEMPLATES )
set( OKTETA_BUILD_INTERNAL_TEMPLATES NOT OMIT_INTERNAL_TEMPLATES )

65 66 67
# mobile needs
option(OKTETA_MOBILE_UI "Build UI for mobile devices instead of for desktops" FALSE)
if (OKTETA_MOBILE_UI)
68
  find_package(Qt5Quick REQUIRED)
69 70
  add_definitions( -DOKTETA_MOBILE_UI )
endif (OKTETA_MOBILE_UI)
71

72 73 74
add_definitions(
    -DQT_USE_FAST_CONCATENATION
    -DQT_USE_FAST_OPERATOR_PLUS
75 76 77 78 79 80 81 82
)
# switch between no cast to/from ascii and a warning about it
if (KDE4_ASCII_CAST)
add_definitions(
    -DQT_ASCII_CAST_WARNINGS
)
else (KDE4_ASCII_CAST)
add_definitions(
83 84 85
    -DQT_NO_CAST_TO_ASCII
    -DQT_NO_CAST_FROM_ASCII
)
86
endif (KDE4_ASCII_CAST)
87

88
# helper libs
89
add_subdirectory( libs )
90
add_subdirectory( doc )
91

92
set( OKTETALIBS_MAJOR_VERSION 0 )
93
set( OKTETALIBS_MINOR_VERSION 8 )
94
set( OKTETALIBS_PATCHLEVEL_VERSION 1 )
95 96
set( OKTETALIBS_VERSION "${OKTETALIBS_MAJOR_VERSION}.${OKTETALIBS_MINOR_VERSION}.${OKTETALIBS_PATCHLEVEL_VERSION}" )
set( OKTETALIBS_ABI_VERSION 1 )
97
set( OKTETALIBS_INCLUDE_INSTALL_DIR  ${INCLUDE_INSTALL_DIR}/okteta${OKTETALIBS_ABI_VERSION} )
98
set( OKTETALIBS_CCINCLUDE_INSTALL_DIR  ${INCLUDE_INSTALL_DIR}/KDE/Okteta${OKTETALIBS_ABI_VERSION} )
99

100 101 102 103
set( oktetacore_LIB  oktetacore )
set( oktetagui_LIB   oktetagui )
set( oktetacore_LIB_NAME  okteta${OKTETALIBS_ABI_VERSION}core )
set( oktetagui_LIB_NAME   okteta${OKTETALIBS_ABI_VERSION}gui )
104

105 106
set( OKTETALIBS_LIB_SOVERSION ${OKTETALIBS_ABI_VERSION} )
set( OKTETALIBS_LIB_VERSION ${OKTETALIBS_VERSION} )
107

108
# Okteta libs
109 110
add_subdirectory( core )
add_subdirectory( gui )
111
add_subdirectory( designer )
112

113
# Okteta Kasten components
114
add_subdirectory( kasten )
115
# special mimetypes
116
add_subdirectory( mimetypes )
117

118
# programs and parts for desktop
119 120
add_subdirectory( parts )
add_subdirectory( program )
121 122

# program for mobile
123
if (Qt5Quick_FOUND AND OKTETA_MOBILE_UI)
124
    macro_optional_add_subdirectory(mobile)
125
endif ()
126

127
feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)